StarCraft® II

unable to connect to battlenet

Hi im having an issue whereby i cant login to SC2 SEA servers despite my internet perfectly fine. This issue happened suddenly although i could play 2 days ago.

When i click login, the "connecting to battle.net" popup appears along with the message that the game is waiting for a response from battlenet. Then it just continues to load forever.

im using a windows 7. internet connection is fine able to stream 1080. firewall and port settings are in order.

please advise
Reply Quote
here are the specs:

OS: windows 7
Anti-virus: AVG 2012 & McAfee Internet Security Suite (expired)
Wireless internet

can anyone help? the problem has been going on for 5days now
Reply Quote
Blizzard Employee
Hi shaunkwan ,

Recently, we've been reported this issue by customers who were on the same page with you and it turned out that that program blocks the authenticated record from the Battle.net Cache folder

So,firstly, remove AVG anti-virus software and then you need to contact AVG and ask them to allow this program to access to Battle.net Cache folder
Reply Quote
Thanks for getting back to me.

I've tried unistalling AVG but the problem still persists.

Any further recommendations?
Reply Quote
Blizzard Employee
Are you using a router or wireless connection?
Recently, have you changed your PC setting?

I cannot see your PC environment directly, but here are troubleshoots from my anticipation

A. Try temporarily disabling router and connect your modem directly to your computer.

B. Try temporarily disabling any firewall or virus security programs that you are running:

a. Right-click on [My Network Places]
b. Select [Properties]
c. Click [Local Network Connection or Modem]
d. Click [Advanced]
e. Uncheck [Internet Connection Firewall]

C. You need to get your port opened
* If you are on WINDOW 7, please click following link
http://us.battle.net/support/en/article/opening-ports-for-the-blizzard-downloader-on-windows-7-firewall

D. If you are running Windows 7, please right-click the game icon and choose Run as administrator.

E. Try launching the game from selective startup mode:

Hit the Windows Key + R, and type: msconfig
Hit Enter or OK.

In the General tab:
1. Choose Selective Startup
2. Disable (uncheck) Load Startup Items
3. Click OK and Reboot

F. Check LAN settings:
If you didn't install or set up any proxy settings, go to Internet Explorer -> File, then make sure Work Offline isn't checked.
Also check Internet Explorer -> Tools -> Internet Options -> Connection -> LAN Settings and make sure your proxy information is correct.
If you don't use a proxy, make sure that everything is unchecked and hit OK

Hope this would help you and thank you for your efforts in advance :-)
Reply Quote
solved it by uninstalling McAfee.

thanks for all the help appreciate it :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]